Cadillac XLR Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Own a XLR since four weeks - love this car.
Yesterday the XLR suddenly started to shift very hard into the lower gears.
Today it became even worse and the "check enginge" light went on.:cry

As my next Cadillac dealer is 120 miles away, I will be so happy, if anyone of you can give me a hint.
 

·
Registered
Joined
·
343 Posts
Have you checked your transmission fluid level?

CC
Checking the transmission fluid level is non-trivial.

1/ Fluid temperature must be between 30-50 degrees C / 86-122 degrees F. (I guess fully warmed up)

2/ Engine running, hold down brake pedal firmly and move shift lever through all ranges, leaving it in each range for a few seconds; return to park.

3/ Raise your XLR on a hoist, engine running, car exactly level.

4/ Remove transmission level hole plug (caution, hot!). (There seem to be two plugs, one at the front and one at the rear of the transmission assembly, above the sump level in the left hand (driver's) side of the transmission casing (this is from a 2004 XLR)).

There is an extended warning about doing this, basically the engine must stay running or hot oil will pour out of the level filler.

"Caution, the engine must be running when the transmission fill plug is removed, or excessive fluid loss will occur. Transmission fluid may be hot. Since the actual fluid level is unknown, stand clear when removing the fill plug. Have a container ready to capture any lost fluid. Do not turn the engine off with the fill plug removed, as you can be injured by the hot transmission fluid being expelled out of the oil fill opening."

5/ No mention is made as to how you actually check the level, I guess fluid should just drip out. I would be very reluctant to stick my finger into a moving transmission to feel for the fluid level and anyway, it will be hot!

6/ If the level is low, add Dexron III in 0.5l / 0.5qt quantities until it drips out. (Suggest you read this site re the proper fluid, there have been a number of tech bulletins on the correct additives etc.) (Does anyone know, is Dexron IV + additives or Dexron LS recommended now?)

7/ If you add more than 1.5l, check for a leak (it says). (My view would be that even 1.5l is a lot).

Perhaps others can add their views?

Harsh shifts can be caused by a number of factors, the best advice is to get those codes scanned, see what shows up. Output speed sensor, input speed sensor or throttle position sensor are candidates.

My preference would be to scan for the fault codes before I tried to measure the fluid level.

See also
http://www.xlrforum.com/showthread.php?t=5986
http://www.xlrforum.com/showthread.php?t=5171

HTHs
 

·
Registered
Joined
·
185 Posts
Tranny Issue

I seem to have a issue when I go under hard acceleration that I hear a grinding noise when ever I go hard on the acceleration from 2500-3500 RPM's. I have had a new tranny put in the car at 100,000KM and the car does have 130,000KM on it now. Could it be low on fluid or should I change the transmission fluid on it?
 

·
Registered
Joined
·
343 Posts
I seem to have a issue when I go under hard acceleration that I hear a grinding noise when ever I go hard on the acceleration from 2500-3500 RPM's. I have had a new tranny put in the car at 100,000KM and the car does have 130,000KM on it now. Could it be low on fluid or should I change the transmission fluid on it?
In my experience, such as it is, trannies do not leak significant quantities of fluid, or if they do it is in such quantities that the fluid is everywhere and a quick check under the car will show transmission fluid all over the place.

If you haven't got transmission fluid dripping under the car then (at a guess, and it is only a guess), the level is probably OK. The service instructions recommend looking for a leak only if you have to add more the one and a half quarts (three pints/1.5l) of fluid. That amount of fluid spilt out is going to make a big mess, even if most of it is out on the highway somewhere, there is still going to be a fair amount left under your XLR. Don't forget that transmission fluid can leak from anywhere in the system, including the cooler lines and inside the radiator.

Diagnosing the description of a sound through a forum such as this is desperately difficult. Changing the transmission at 100,000km seems early, (thats about 60,000 miles) so only getting another 30,000km (20,000 miles) does not seem good. Was the diff replaced too?
 

·
Registered
Joined
·
185 Posts
No the differential was not replaced but they said they added in the additive to stop the noise. I do know however when I do hear that sound it I can feel it through the shift knob. So it could be the differential making that sound and the grind vibration is traveling through to the tranny? I am thinking that is the possible scenario since there is no leaking underneath the car what so ever and as you said for the tranny to be doing would be high unlikely.

I will wait for further comments but I am thinking of doing a rear end flush and fill. Which rear diff fluid would be recommended and which brand???
 

·
Premium Member
Joined
·
1,948 Posts
No the differential was not replaced but they said they added in the additive to stop the noise. I do know however when I do hear that sound it I can feel it through the shift knob. So it could be the differential making that sound and the grind vibration is traveling through to the tranny? I am thinking that is the possible scenario since there is no leaking underneath the car what so ever and as you said for the tranny to be doing would be high unlikely.

I will wait for further comments but I am thinking of doing a rear end flush and fill. Which rear diff fluid would be recommended and which brand???
Tony, use the GM Corvette Positraction Fluid and the additive. If you are uncomfortable with that or the noise doesn't go away use Mobile1 Positraction fluid (the whisper fix in my dealers shop)



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #8 ·
Now even speed control fails

Thank you for all your answers.
Will have the chance to check the trans fluid level tomorrow.
Today I noticed that the engine does start not always at the first trial and that the speed control and the distance function fails as well.
It seems I have to ride the long way to the Cadillac shop.:cry
 

·
Registered
Joined
·
343 Posts
I do know however when I do hear that sound it I can feel it through the shift knob. So it could be the differential making that sound and the grind vibration is traveling through to the tranny?
Yes, it is certainly possible, but whether that is the cause, I couldn't say. You might have drive line vibration, engine vibration, there are various alternatives. If it is bad enough raise it as a service issue. Which country are you located in? Do you get good Cadillac XLR support?
 

·
Registered
Joined
·
185 Posts
Hey all;

I did the rear oil change for the differential today and it seems to have eliminate the problem so far. A note to mention however is on the 04 to remove the drain plug you need a "L" shape allen key since theres barely any room to get into there. I did notice that the oil was black and contained a few metal shavings but that is expected. Now I don't know when the dealer added the additive if they change the fluid or just added it to the existing one? I am however keeping a record book of my car and will be doing the rear oil change every 2 years.

If anyone needs more detailed steps I suggest going to corvetteforums.com and searching "Rear differential change for C6" since it's exactly the same.
 

·
Premium Member
Joined
·
1,948 Posts
Hey all;

I did the rear oil change for the differential today and it seems to have eliminate the problem so far. A note to mention however is on the 04 to remove the drain plug you need a "L" shape allen key since theres barely any room to get into there. I did notice that the oil was black and contained a few metal shavings but that is expected. Now I don't know when the dealer added the additive if they change the fluid or just added it to the existing one? I am however keeping a record book of my car and will be doing the rear oil change every 2 years.

If anyone needs more detailed steps I suggest going to corvetteforums.com and searching "Rear differential change for C6" since it's exactly the same.
Tony:

You may have to change it again real soon and include the additive again. What is happening is typical Corvette positraction stuff. The positraction plate are sticking.



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
 

·
Registered
Joined
·
185 Posts
Okay because the only thing is that I never added the additive since it said it was included in the oil and I read also on the corvette forum that all the new solutions have it in it anyways.
 

·
Premium Member
Joined
·
1,948 Posts
Okay because the only thing is that I never added the additive since it said it was included in the oil and I read also on the corvette forum that all the new solutions have it in it anyways.
Check your invoice copy and see if they used these parts.

-- Positraction Additive GM PART # 1052358 (used in other GM models).
-- GM Synthetic Differential Fluid GM PART #89021669.



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #16 ·
Problem solved

Just for your information:
The trans fluid level was a bid too low but not the general reason for the failure: Since updating the pogramming/software of the XLR, the car drives as smooth and perfect as new.
So I can fully enjoy my ride again.
 

·
Registered
Joined
·
106 Posts
Mine was hard shifting between I believe 2 & 3 up and down. When I would start off, it would leap, rather than a smooth start. I also had the grinding sound when I stepped on it.
After many weeks in the dealer, the shifting problem was corrected with a new computer in the transmission. It also corrected the leaping problem. The grinding was the exhaust not aligned properly.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #18 ·
Solved - it was a low trans fluid level

Sorry for my very late reply.
A cup of trans fluid solved the issue - the level was a bit too low.
I drove about 10.000 miles since then without any problem.

Thank you for your hints and advices.

I love this car:yesnod
 
1 - 18 of 18 Posts
Top