Cadillac XLR Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
My information button came accross today saying service traction system. Has anyone here had this problem with their 05 xlr? I guess i am going to call a dealership right now to schedule an appointment for the car. Crazy and depressing.
 

·
Registered
Joined
·
1,142 Posts
have you restarted since it came on?
I've had it come on a few times and be gone after restarting.
Dealer says no service needed
 
G

·
Any two footed driver has this problem. If the computer thinks your car is out of sorts, by press the brake and the accelerator at the same time, it will throw a code, but should go off when restarted. Keep in mind you have no traction control or stabilitrak while that light is on, and can loose it in a corner.............I know. I stop the car and restart it ASAP and don't wait to get home.
Bob
My information button came accross today saying service traction system. Has anyone here had this problem with their 05 xlr? I guess i am going to call a dealership right now to schedule an appointment for the car. Crazy and depressing.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #4
I restarted it twice and the check engine light still stays on but the display for the service is gone. I have not driven it today since then though. Tell me about it, I am so use to driven standards (my whole life), it's weird driving an automatic.

It figures something would go wrong i Just got my corsa exhaust in the mail TODAY. (From Jim) I was going to try to get it on this weekend.
 
G

·
OK, at least you have TC/Stabilitrak now, so I guess you will have to go to the dealer to find out why the engine light is lit. It probably threw a code and until they remove it, it will stay lit. Do you drive with both feet?
Bob
I restarted it twice and the check engine light still stays on but the display for the service is gone. I have not driven it today since then though. Tell me about it, I am so use to driven standards (my whole life), it's weird driving an automatic.

It figures something would go wrong i Just got my corsa exhaust in the mail TODAY. (From Jim) I was going to try to get it on this weekend.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #7
light off

It went off last night. I think its because i drove a standard for 15 years and this is my first automatic. I probably hit both at the same time by accident and didn't realize i did.
:eek
 

·
Registered
Joined
·
272 Posts
How would hitting the brake and the gas at the same time create a problem? I've done it a few times and never got any strange signals...
 

·
Registered
Joined
·
189 Posts
I had the same problem and it was a sensor in steering wheel, the dealership in Colorado Springs was abe to fix in about two hours. I have touched both the brake and throttle at the same time and had no problems.:cheers :jester
 
G

·
I just report what Allen Cadillac told me. That doesn't make them right.
All I know is it's not a good thing to be taking corners at high speeds with no TC on, unless your good at drifting.
Bud, can you add anything to your thread about the steering wheel causing the TC to go off?
Bob
 
1 - 11 of 11 Posts
Top