Cadillac XLR Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
Got to work this morning, shifted to Park and car started moving backwards. Attempts to shift to any other gear had no effect. Shifter moves fine, it just does not do any thing. Shut the car off and not will not restart. Any ideas what this is??? FWIW it is unseasonably cold here, 40 degrees. Also, it just occurred to me that for the last week or so the automatic headlights want to be on in broad daylight, abnormal behavior.
 

·
Premium Member
Joined
·
1,100 Posts
Troubleshooting something like this over the Internet would likely be as conclusive as determining a home pregnancy test result by taste in a dark room, but there are a few symptoms in your post that might shed some light on possible causes.

The shift lever isn't a mechanical linkage like the old days. It's a switch that sends a signal (depending on position) to the HUD and Transmission Control Module. If the proper shift lever position signal isn't received by the Run/Crank Relay Control circuit, the car won't start.

Since you noticed the headlamps were acting kind of flaky during daytime operation, it could be related. Anytime the car starts acting bi-polar, the battery and it's connections are always a good first thing to check. Nominal voltage (as read on the Instrument Panel Cluster) doesn't mean a battery is necessarily good, but a low reading spells trouble. Of course, that would probably generate a message too. . .

But it's worth checking out because the battery voltage is fed to the shift lever and transmission shift lock circuit via Fuse 19 (10 amp) in the Body Control Module under the passenger side toeboard. (The owner's manual says it's BCM fuse 10, but the repair manual sticks with fuse 19.)

If the battery checks out, the power distribution network is working, and the shift lever is good, the Transmission Control Module might be suspect. The only way to know for sure is to have the car connected to a Tech 2 and receive a full diagnostic, which of course, means a tow to a dealer if you can't get it started.

I wish I could tell you more, and hope you get this resolved as quickly (and cheaply!) as possible. Please write back and let us know what ultimately fixes this.

CC :seeya
 

·
Registered
Joined
·
343 Posts
Got to work this morning, shifted to Park and car started moving backwards. Attempts to shift to any other gear had no effect. Shifter moves fine, it just does not do any thing. Shut the car off and not will not restart. Any ideas what this is??? FWIW it is unseasonably cold here, 40 degrees. Also, it just occurred to me that for the last week or so the automatic headlights want to be on in broad daylight, abnormal behavior.
Is that 40 degrees below freezing (i.e. -8F) or is that +40 degrees, i.e. +8F above freezing? If it is +40 degrees, then that is not a low temperature. The advice re the battery is good, can you get a second, known good battery and some decent booster cables connected? If so, see if the problem clears.

All the best.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #4 ·
+40F, The car was towed to the dealer yesterday after closing time and left outside their fence in their front parking lot. As of 2:00 today they still have not looked at it. Now they tell me they have no way of moving it into the garage!!! They have got to be kidding!

First time I have ever had a car towed. Very scary. They had to send three trucks before they sent one that was properly equipped. Then he rammed the tailpipes and bumper with the thingy that goes under the car.

My baby has been defiled.
 

·
Registered
Joined
·
343 Posts
+40F, The car was towed to the dealer yesterday after closing time and left outside their fence in their front parking lot. As of 2:00 today they still have not looked at it. Now they tell me they have no way of moving it into the garage!!! They have got to be kidding!

First time I have ever had a car towed. Very scary. They had to send three trucks before they sent one that was properly equipped. Then he rammed the tailpipes and bumper with the thingy that goes under the car.

My baby has been defiled.
Re the headlights, I haven't tried this as I leave them in Auto, but if you have turned them on manually, do they always come on with the ignition? Just a thought. Apart from a battery problem, I can't think of anything that would link the two. It could just be coincidence, or just maybe the lights are on too long and are killing off the battery?

The dealer could scan your XLR for codes right where it is now...., or how about a voltage check?
 
1 - 5 of 5 Posts
Top