Cadillac XLR Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
In the two years I have had my 2005 XLR I have not had any problems, except for a few minor, temporary glitches unrelated to the top.

The other day when I tried to raise the top, the trunk opened as usual, the small section moved, but the main roof section would not raise out of the trunk even though the top motor was running. I could reclose the trunk, but the main section would not raise. At least I could drive the car. The next day, the top went up and everything worked OK. I took it to the dealer anyway. They had it all day and could not duplicate the problem.

The next day as soon as I started the car, the message TOP NOT SECURE was displayed. I pushed the button to open the trunk. The trunk motor started, but instead of opening immediately, the motor ran about 5 seconds, then the trunk opened, and even when fully opened, the trunk motor continued to run another 5 seconds. The trunk closed OK. The same thing happened trying to open the trunk again. After repeating this sequence about 6 times, the trunk resumed normal operation. The top opened OK. When trying to close the top, the main section would not raise again. I shut off the car, got out, waited 5 minutes, tried again, with the same results. After trying several times, the message TOP MOTOR OVER TEMP was displayed, with the trunk stuck up. I shut off the car, waited 10 minutes, and was able to reclose the trunk. I took it to the dealer all day today. They opened and closed the top about 15 times with no problems. They could get no error code diagnostics, even after doing a diagnostics upgrade that gave a reading on the car body error codes. It worked OK for me this evening also. Almost wish they had found something definitely wrong.

Does anyone have a guess as to the problem, and a suggestion as to what to tell the dealer to look at if this happens again? Thanks.

Jerry
 
G

·
Jerry.
I learned by removing one of your battery cables for about 20 seconds, it reboots the computer and many of the opertions will work normally again. It's worth a try
Bob
In the two years I have had my 2005 XLR I have not had any problems, except for a few minor, temporary glitches unrelated to the top.

The other day when I tried to raise the top, the trunk opened as usual, the small section moved, but the main roof section would not raise out of the trunk even though the top motor was running. I could reclose the trunk, but the main section would not raise. At least I could drive the car. The next day, the top went up and everything worked OK. I took it to the dealer anyway. They had it all day and could not duplicate the problem.

The next day as soon as I started the car, the message TOP NOT SECURE was displayed. I pushed the button to open the trunk. The trunk motor started, but instead of opening immediately, the motor ran about 5 seconds, then the trunk opened, and even when fully opened, the trunk motor continued to run another 5 seconds. The trunk closed OK. The same thing happened trying to open the trunk again. After repeating this sequence about 6 times, the trunk resumed normal operation. The top opened OK. When trying to close the top, the main section would not raise again. I shut off the car, got out, waited 5 minutes, tried again, with the same results. After trying several times, the message TOP MOTOR OVER TEMP was displayed, with the trunk stuck up. I shut off the car, waited 10 minutes, and was able to reclose the trunk. I took it to the dealer all day today. They opened and closed the top about 15 times with no problems. They could get no error code diagnostics, even after doing a diagnostics upgrade that gave a reading on the car body error codes. It worked OK for me this evening also. Almost wish they had found something definitely wrong.

Does anyone have a guess as to the problem, and a suggestion as to what to tell the dealer to look at if this happens again? Thanks.

Jerry
 

·
Registered
Joined
·
68 Posts
To save you from having to look it up, here is how to do it according to the 2007 manual:

Power Window Initialize
After a power reconnect such as battery
replacement, the express-up and index-up features
will not function until the system is initialized.
Once power is restored, do the following:
1. Close the door.
2. Raise the window by holding the up arrow on
the power window switch.
3. Hold the up arrow for three seconds after the
window is closed. Release the switch. Then
hold the up arrow again for three seconds.
The express-up system must be initialized to
operate the windows with the door open.
 

·
Registered
Joined
·
145 Posts
In the two years I have had my 2005 XLR I have not had any problems, except for a few minor, temporary glitches unrelated to the top.
I have been having similar problems and in fact just got my car out of the shop after it was there for 1.5 days. The modulator (computer) had to be reprogrammed to resolve the issue yet they did not know why it keeps going out of sync.

Bill
 

·
Registered
Joined
·
1,142 Posts
Ok since we're on computer glitches.........(sorry to hijack your Top Problem thread).
I took my V in last week for the 10k oil change. when they reset the "oil life remaining" ....the CEL came on.
To rid the CEL, they decided to FLASH THE COMPUTER!!:mad
It got rid of the CEL....and everything else I have taught my car over the last year and a half.
Suggest everyone avoid allowing this whenever possible.
 
1 - 6 of 6 Posts
Top