Scan Tool Interface Problem - Cadillac XLR Forum: XLR and XLR-V Forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 12-21-2015, 04:13 PM Thread Starter
Member
 
Join Date: Apr 2014
Location: New York
Posts: 4
Intermittent OBD 2 reads

When I plug my OBD 2 reader into the port, the reader will read all codes, if any, sometimes. Other times it has trouble linking with the ECU, I presume, and won't read anything. The reader says " linking error". What could cause that problem? Thank you in advance for your help.
Sayhey is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 12-31-2015, 08:33 AM
Administrator
 
ccclarke's Avatar
 
Join Date: Mar 2008
Location: New England '13 XTS Platinum
Posts: 1,100
Trying to properly troubleshoot an issue like this is next-to-impossible over the Internet. You could have a DLC connector problem, a hardware fault with your scan tool, a timing issue with the buss, etc.

While the XLR is OBD II compliant for reading power train codes, a Tech 2 is your best bet, and does a whole lot more.

Have you used your scan tool without any problems on another car?

CC
ccclarke is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Cadillac XLR Forum: XLR and XLR-V Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome