ONSTAR remote diagnostics problem - Cadillac XLR Forum: XLR and XLR-V Forums
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 07-26-2008, 07:25 PM Thread Starter
 
Join Date: Sep 2005
Posts: 69
ONSTAR remote diagnostics problem

Ever since I had the digital upgrade done to the On Star system my remote diagostic report from them has been incorrect. I have been to the dealer several times and have contacted on star to no avail. Has anyone had this problem or have any suggestions.

The system monthly reports emission, engine, transmission and antilock brake problems that are non existant.
Other reports are correct.

JIM
xlrjim is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 07-26-2008, 07:56 PM
 
Join Date: May 2007
Posts: 224
OMG I LOVE YOU! I've had the same problem since "upgrading" to Digital! This is another one of those problems where I'm greeted with "Gee, I've never seen that before!".

I spoke to Len Tillard at BGIII and emailed him and OnStar the details - OnStar is supposedly working on it.

I first noticed it when I received my first OnStar report on my car which is emailed to me every month. I'll be sure to let you know what the issue is, if it ever gets resolved. Of course, my warranty is up in 2 weeks.

TO OTHER FORUM MEMBERS WHO HAVE HAD THE UPGRADE COMPLETED: Call OnStar and ask for a System Diagnostic. When they say everything is fine, ask them what the report says about the transmission. When they say "I am unable to complete the test" TAKE IT BACK TO THE DEALER!!! SOMETHING IS WRONG!!

Maybe I'll have an answer in the next week or 2.....
homegameroom is offline  
post #3 of 14 (permalink) Old 07-26-2008, 10:42 PM
Registered User
 
Join Date: Feb 2007
Location: Santee, CA .... '04 Raven Black
Posts: 610
Jeesh .... yes .... I've had that happen too ... but have sort of shoved it to the backburner. I knew nothing was really going on with the car. I am DREADING another trip to the service department. ..... Isn't there an easier way to do this??

RA
Lola's mom is offline  
Sponsored Links
Advertisement
 
post #4 of 14 (permalink) Old 07-27-2008, 11:10 AM
Member
 
weaston's Avatar
 
Join Date: Sep 2007
Location: Phoenix, Arizona
Posts: 21
OnStar Diagnostics error

My service tech told me it has something to do with the wiring/antenna in either the trunk or mirror, can't remember which. He said he ordered the part and would call me when it arrived, never heard back from him, and like you I dread going to the dealer so haven't followed up yet. Will let you know when I call him this week, that is, if I get an answer.
weaston is offline  
post #5 of 14 (permalink) Old 08-09-2008, 07:25 AM
 
Join Date: May 2007
Posts: 224
I hope I have the answer:

I took my car in this week for the "Check Engine" light; I also mentioned the OnStar problem. The service advisor kind of groaned, and said they'd had issues with the upgrade. I was thinking nothing might happen, until I picked up the car.

It appears that OnStar needs to upgrade the software AFTER the digital upgrade is installed. I called OnStar to ask how the transmission was doing, and they said they could see no issues. They also said they could connect to it!

Here's the details of the repair from my repair invoice, typed in verbatim:

CUST STATES ON STAR CAN NOT READ CODES FROM CAR

CAUSE: UPDATE PROGRAM TAC 10422709 FOR ECM
J6354 POWERTRAIN CONTROL MODULE ENGINE
REPROGRAMMING WITH SPS

..23831 UPDATED SOFTWARE. HAVE OVER AN HOUR IN THE REPAIR. CALLED ONSTAR AND VERIFIED THAT THEY CAN NOT READ ECM CODES. CALLED TAC AND OPEN CASE # 10422709. THEY TOLD ME THAT ONSTAR HAD TO UPDATE THE SOFTWARE. TALKED TO TAC 2 MORE TIMES BEFORE ONSTAR UPGRADED THE SOFTWARE.

I hope this information is helpful!!!!!

So far, everything seems to be working - I'll get my next email from OnStar about my car and it's systems on September 4, so I'll know for sure then.

BTW, if you do get those emailed reports, check them out! You can get all the history of the car, average miles driven, when the oil was changed and other information by clicking on the included links. I think it's pretty cool!

Last edited by homegameroom; 08-09-2008 at 07:27 AM.
homegameroom is offline  
post #6 of 14 (permalink) Old 08-09-2008, 09:15 AM
Member
 
weaston's Avatar
 
Join Date: Sep 2007
Location: Phoenix, Arizona
Posts: 21
Onstar

Great info to have. Wish I had known before I went to the dealer Friday morning who tried to talk me into installing a new "bump" on the trunk. Turns out he said it would address my satellite reception problem, but not the Onstar issue. Didn't even mention reprogramming after the digital upgrade. BTW, now they're recommending not painting the bump any longer to improve functionality, but he showed me one unpainted and it was not attractive, so stuck with my old painted one.

Anyway, thanks for the info, will try the upgrade, and anticipate my next monthly report around the time you get yours, hopefully without all those faux errors.
weaston is offline  
post #7 of 14 (permalink) Old 08-09-2008, 10:43 AM
Registered User
 
Join Date: Feb 2007
Location: Santee, CA .... '04 Raven Black
Posts: 610
Really good post, Richie ....

I am printing this out and taking it to the dealer with me .... I think it will save everyone a lot of time and trouble .... especially me!

RA
Lola's mom is offline  
post #8 of 14 (permalink) Old 08-09-2008, 09:03 PM
 
Join Date: Aug 2005
Posts: 333
Does anyone know if these problems were only on older upgrades? I had the upgrade done about 4 weeks ago. I wonder if this was corrected by then?
upstate is offline  
post #9 of 14 (permalink) Old 08-26-2008, 08:19 PM Thread Starter
 
Join Date: Sep 2005
Posts: 69
Success!!!!

My dealer and On Star finally got it right and my On Star diagnostics are working fine.

the dealer replaced the R5140 interface unit and downloaded new software to finally get it working..

Thats the good news, the bad news is that it to 5 monthly complaints and considerable phone calls and emails to On Star to get it right.
xlrjim is offline  
post #10 of 14 (permalink) Old 08-26-2008, 08:57 PM
Registered User
 
Join Date: Feb 2007
Location: Santee, CA .... '04 Raven Black
Posts: 610
Congratulations! I am still stalling on taking Lola in ....

RA
Lola's mom is offline  
post #11 of 14 (permalink) Old 08-28-2008, 10:19 AM
Registered User
 
Join Date: Feb 2007
Location: Santee, CA .... '04 Raven Black
Posts: 610
I KNOW this has been addressed somewhere before .... but can someone please give me a refresher course ....

I have OnStar .... just renewed it .... but they took my phone minutes away from me ..... again. Can't I have both OnStar and put my phone on my Verizon account??? And who do I contact to do that? OnStar has never been any help in that area .....

RA
Lola's mom is offline  
post #12 of 14 (permalink) Old 08-28-2008, 10:28 AM
XLR Pit Crew
 
XLR_Lover's Avatar
 
Join Date: Jul 2007
Location: Spring Hill, Fl
Posts: 553
HA!!!

Funny you should mention the minutes!

I received a notice that I would lose my 158 minutes as my contract year (only with the phone side) was about to expire. I called and asked "why do minutes I paid for expire????. The answer was "many things expire, like cereal," I replied "minutes don't get stale as cereal does," anyway, I spoke to someone higher up and she was nice enough to extend my minutes w/o buying more. Today I received an e-mail to buy more minutes and it showed I had 0 minutes. I was about to call, but before I called I went and verified the available minutes by using the car phone-- I was told I now have 354 minutes available--I decided not to call.

Floyd
XLR_Lover is offline  
post #13 of 14 (permalink) Old 08-28-2008, 05:53 PM
Registered User
 
Join Date: Feb 2007
Location: Santee, CA .... '04 Raven Black
Posts: 610
Well, not only can I use some help with my Verizon question .... but I have a definite answer on whether the fob stays active in the trunk.

No, it doesn't

Went to CostCo today, loaded everything into the trunk .... including my purse .... (I know, I know ...) ..... hit the button to close the trunk ..... saw my purse and started yelling "Noooooooooooooooooooooooooooooooooooooo!" .... To late ... click. The nicest guy in the world heard/saw what happened and lent me his cell phone so that I could get an OnStar unlock ... I still don't know how that works .... Now - if I leave my purse in the car ..... the car will not lock .... done that too. I should really be embarassed .... but it was so typical of everything else this week ....
Lola's mom is offline  
post #14 of 14 (permalink) Old 09-03-2008, 09:51 AM
 
Join Date: May 2007
Posts: 224
Quote:
Originally Posted by homegameroom View Post
I hope I have the answer:

I took my car in this week for the "Check Engine" light; I also mentioned the OnStar problem. The service advisor kind of groaned, and said they'd had issues with the upgrade. I was thinking nothing might happen, until I picked up the car.

It appears that OnStar needs to upgrade the software AFTER the digital upgrade is installed. I called OnStar to ask how the transmission was doing, and they said they could see no issues. They also said they could connect to it!

Here's the details of the repair from my repair invoice, typed in verbatim:

CUST STATES ON STAR CAN NOT READ CODES FROM CAR

CAUSE: UPDATE PROGRAM TAC 10422709 FOR ECM
J6354 POWERTRAIN CONTROL MODULE ENGINE
REPROGRAMMING WITH SPS

..23831 UPDATED SOFTWARE. HAVE OVER AN HOUR IN THE REPAIR. CALLED ONSTAR AND VERIFIED THAT THEY CAN NOT READ ECM CODES. CALLED TAC AND OPEN CASE # 10422709. THEY TOLD ME THAT ONSTAR HAD TO UPDATE THE SOFTWARE. TALKED TO TAC 2 MORE TIMES BEFORE ONSTAR UPGRADED THE SOFTWARE.

I hope this information is helpful!!!!!

So far, everything seems to be working - I'll get my next email from OnStar about my car and it's systems on September 4, so I'll know for sure then.

BTW, if you do get those emailed reports, check them out! You can get all the history of the car, average miles driven, when the oil was changed and other information by clicking on the included links. I think it's pretty cool!
Well, I received my cars September OnStar report, and everything looks great! The repair (reprogramming) worked perfectly! I hope this helps those of you who are having the same issue.

Rich
homegameroom is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Cadillac XLR Forum: XLR and XLR-V Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome