memory seat [Archive] - Cadillac XLR Forum: XLR and XLR-V Forums

: memory seat


harry yarnell
09-26-2005, 01:31 PM
I no longer have automatic memory seat. Used to be, start the engine, and the seat and steering wheel would move to the memory 1 position. Not any more. I can manually push the memory button, and it resets; I've tried resetting the memory, no luck.
The seat and wheel move out of the way when you open the door, and that's the position it remains in when you start. Any ideas why, or what I need to 'reprogram', before I take it in?

aviator
09-26-2005, 04:46 PM
I would definitely try a couple of things first:
1) Replace the battery in the key fob.
2) Reprogram the seats to your desired settings.

Then perform a test.

Did you disconnect your car battery for any reason?

Eyedoc
09-27-2005, 07:03 AM
That's right. I had mine in for work some months back and the dealer must have disconnected the battery during their work. I had to redo the settings on the memory functions (seat, mirror, radio). Now its fine again.

harry yarnell
09-28-2005, 02:18 PM
Nope, nothing helps. The DRIVER 1 and DRIVER 2 presets are still there, but manually; you have to push the button. Neither fob will move the seat. The seat and wheel will retract at shutdown, but won't re-position at startup. Guess it's off to the dealer again.

2xlrs
09-28-2005, 03:52 PM
Have had this happen - have you tried resetting the options under driver 1 and driver 2 on the dash settings. These were reset once when I had mine at the dealer not to remember the settings and I had to reset them

harry yarnell
09-29-2005, 06:13 AM
No, how do you do that?

carlnorum
07-11-2008, 03:36 PM
This just started happening to me - anybody have a known fix? I need to take the car in for service anyway (air bag light), but I'd like to fix it myself if I can.

RickH
07-11-2008, 07:29 PM
Just had to reset the seat positions yesterday.

Use the following steps to program each button:
1. Adjust the driver’s seat including the seatback recliner, lumbar and head restraint, both outside mirrors and the steering wheel to a comfortable position.

2. Press and hold button 1 until two beeps are heard, then release the button.
A second mirror, seating and steering wheel position can be programmed by repeating the above steps and pressing button 2 (for driver 2). Each time a memory button is pressed and released, a single beep will sound. Each time button 1 or 2 is pressed and released while the vehicle is in PARK (P), the memory positions will be recalled after a brief delay. If the vehicle is not in PARK (P), three beeps will be heard and the memory position will not be recalled. When the engine is started, the seat, mirrors, and steering wheel may automatically adjust to their
programmed positions. To stop recall movement of the memory feature at any time, press one of the power seat controls, power
mirror control buttons, memory buttons, or power steering column control.

Two personalized exit positions can be set by first recalling the driving position (by pressing 1 or 2), then positioning the steering wheel and seat in the desired exit positions and then pressing and holding the exit button until two beeps are heard. The exit button is located between buttons 1 and 2. With the vehicle in PARK (P), the exit position for the previously set driver can be recalled by pressing the exit button.

When you use the keyless access transmitter to unlock your vehicle, automatic seat and steering wheel movement to the exit position may occur. The numbers on the back of the transmitter, 1 and 2, corresponds to the numbers on the memory buttons. Further programming for automatic seat and mirror movement can be done using the Driver Information Center (DIC).
For programming information, see DIC Vehicle Personalization on page 3-73. 2

RickH
07-11-2008, 07:34 PM
...and then if your FOB doesn't work - change the battery

carlnorum
07-14-2008, 12:02 PM
Turns out it was just a failure to operate the DIC correctly on my part. The UI for that thing is terrible - if you push the "Options" button twice, it changes the state of the entry recall. Boo.

Anyway, resolved now.